Announcement

Collapse
No announcement yet.

Launch Pad Glitching Out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Launch Pad Glitching Out

    I just upgraded to N4 beta (build 143). I'm running it rewired into Logic 9, and the launchpad has stuck lights, or just freezes and doesn't respond. It's seems like this is happening almost exclusively when Numerology is not the selected application.

    When I bring Numerology to the front, the launchpad starts responding again. And sometimes, it goes really fast like it's catching up to everything it's not shown so far.

    The launchpad never did anything like this with N3. I always had numerology minimized or behind Logic when playing. I installed the latest Novation drivers, but I think they were already installed tbh. I've tried different USB ports, but had the same result on all of them.

  • #2
    After some further testing, I can report that this is definitely Rewire related. I launched N4 first to prevent rewire mode, and I couldn't coax any stuck lights or freezing out of the launchpad.

    As soon as I closed N4 and relaunched it in Rewire mode, the problems started up again immediately.

    Also, Logic is crashing when it closes after Numerology is launched in rewire mode. I can only assume it's related to the rewire driver somehow.

    -----

    For one final edit, the Audio Unit doesn't appear to be exhibiting this behavior. I really prefer the rewire method though.
    phase ghost
    Senior Member
    Last edited by phase ghost; 10-11-2014, 05:02 PM.

    Comment


    • #3
      Ok, I'll see if I can replicate the issue... Which Mac OS are you on?

      Thanks,
      Jim

      Comment


      • #4
        10.9.1

        Already e-mailed you, but figured I should keep the thread updated.

        Comment


        • #5
          I made a short video showing the problem here (sorry it's sideways):

          https://www.youtube.com/watch?v=yMu4sFWEGCY

          I started shooting the video after the launchpad stopped responding. When I click on Numerology, making it the selected program, you can see that everything that hasn't been shown yet went by really quick to catch up.

          After I shot this I had the idea to tap a bunch of the control buttons along the side while it was frozen again. It did the same thing, flashing through the seq edit screen, gate length, velocity, etc. So, it's some sort of bottle neck apparently.

          Comment


          • #6
            I found the solution to this problem. The cause was a cute little feature that Apple came up with called "App Nap". In a nutshell, it limits the performance of any program that's not creating audio or the selected (at the front of the screen) application.

            In my case, I was using N4 for midi only, so it qualified for a stupid nap. The solution is quite simple:

            - Go to your applications folder

            - Right click (or option if you're using a mouse without that) on the Numerology 4 app

            - Click the checkbox that says "Prevent App Nap"

            Comment


            • #7
              we had the same issue with EigenD... basically App nap needs to be disabled for all music applications due to them being timing critical,
              (becomes even more vital if you are doing direct comms with external devices over USB, though i thought with Launchpad this would have been done by the driver)

              Jim, you might want to consider disabling, by using activity options, in particular:
              NSActivityLatencyCritical.
              see: http://stackoverflow.com/questions/1...itywithoptions

              Comment


              • #8
                Yup, I was just looking at the same API...

                Jim

                Comment

                Working...
                X