No announcement yet.

Tie note behaviour

  • Filter
  • Time
  • Show
Clear All
new posts

  • Tie note behaviour


    I'm using a mono note sequencer (N4) with tie notes in a 16 note pattern. All the notes are tied except one. The note that is not tied sends a note off/on and the note plays until the next note off/on when the pattern loops round.

    The problem I'm trying to solve is why the start of the sequence, in this case a tied note, sends a midi note /on message, when the sequence is first initiated. This gives me a note/sound where it's not welcome. After the first loop around the "Tie" notes behave as expected: a single long note is generated that is refreshed at selected point in the sequence.

    Is this a bug and is there a work around? - I've tried various things with the mono seq mute buttons I did have some success muting the audio output for the first loop around but that looks like a whole other creative thing for later.
    Attached Files

  • #2
    I wonder if this is related to what I reported in this thread:
    with ties, it appeared to be be re-triggering after 4 notes.
    very easy to reproduce.


    • #3
      Thanks Technobear - I checked out the post and I see the bit about retriggering and it's possibly related. I'm really hoping Jim is going to come along and clarify retriggering + tie notes and the various sequencers.

      I have tried
      - CV seq to midi note gen stack - in case it was related to midi mono note seq
      - midi switch so that it outputs between a synth and nothing
      - Used Presets to switch on/off various mute/filter options i.e. midi filter

      In all the things I've tried the first run through of a looping sequence sends a note on message at the first gate, where the first gate is tied. Second loop through the first gate does not send a note on message and all is good. And thereafter loops & sounds as expected until you make a change i.e. another preset

      Changing presets kicks the first gate sending a note on message all over again even though it's tied.



      • #4
        When the sequencer starts, it has no prior knowledge of what happened before, and it always generates a new gate message, so this is in this case the expected behavior.

        However, there are plenty of ways to get the behavior you want. In particular, you have the sequencer rate at 1/16 note and a length of 16 steps, which is both pretty fast and short for a 'drone' note. You could easily set the rate to whole notes, then set the first step to muted. Then modify the length of the first step to get a delayed start. You can also bump up the length of the sequence to get a 128 bar pattern, or setup a 2nd preset and use the playlist to get a long sustain.